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Johdatus multimediaan harjoitukset: 
Kuvankäsittely 1
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Kuvankäsittely

- Kuvankäsittelyohjelmia:
- Bittikarttakuvat

- Adobe Photoshop
- Corel Photopaint
- Gimp, …

- Vektorigrafiikka
- Macromedia Freehand
- Corel Draw, …

- Kuvankäsittelyohjelmilla on lähes järjestään tarkoitus tehdä 
grafiikkaa painettavaksi tai printattavaksi, jolloin ne [ohjelmat] 
sisältävät toimintoja ja käsitteitä, joita ei tarvita kun tehdään 
grafiikkaa käytettäväksi webissä ja multimediaesityksissä.

- Vektorigrafiikkaan perehdytään toisella harjoituskerralla, mutta ihan 
ensiksi muutamia peruskäsitteitä…
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Väriavaruudet: RGB ja CMYK

- RGB (Red, Green, Blue)
- Televisio ja monitori
- Värien muodostus on additiivinen

- lähtökohtana on musta ja kun kaikkia kolmea osaväriä valitaan tappiin saadaan valkoinen
- CMYK (Cyan, Magenta, Yellow, Black)

- Painotuote
- Värien muodostus on substraktiiviinen

- lähtökohtana on valkoinen ja kun kaikkia kolmea osaväriä valitaan tappiin saadaan musta
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Väriavaruudet: RGB ja CMYK

- RGB:n ja CMYK:n väriavaruudet 
eivät ole täysin yhteneviä

- Painotuotteessa ei voi toistaa kaikkia 
monitorilla näkyviä värejä ja toisinpäin

- Kuvan käyttötarkoitus määrää kumpaa 
väriavaruutta tulee kuvankäsittelyssä 
käyttää

- Prosessivärejä (Cyan, Magenta
Yellow ja Black) käytetään 
neliväripainatuksessa

- Käytännössä pelkällä CMY:llä ei saa 
toistettua mustaa, siksi musta väri

- Mustaa käytetään myös 
alivärinpoistoon (mm. vähentää muiden 
painovärien kulutusta ja painojäljen 
likaisuutta)

- PMS (Pantone Matching System) 
värejä käytetään painettaessa värit 
erikseen.

- Esimerkiksi lomakkeet ja laskut
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Kuvankäsittelyohjelmien värimoodit

- Bitmap
- 1-bittinen (on/off), vaihtoehtoina värit valkoinen ja musta

- Grayscale
- 8-bittinen, jolloin 256 eri harmaan sävyä mustasta valkoiseen
- 16-bittinen, jolloin 65536 harmaan sävyä

- Indexed color
- Värit on indeksoitu, jolloin esimerkiksi 8-bittisessä kuvassa voi olla 256 eri väriä ja 4-

bittisessä 32 eri väriä
- Gif-tallennusformaatti voi tallentaa vain indeksoituja kuvia ja maksimissaan 256 väriä

- RGB
- 24-bittinen, jolloin 8 bittiä/kanava ja pystyy esittämään 16,6 M värisävyä
- 48-bittinen, 16 bittiä/kanava

- CMYK
- 32-bittinen, jolloin 8 bittiä/kanava
- 64-bittinen, jolloin 16 bittiä/kanava

Photoshopissa näitä säädetään valikosta Image-> Mode ->
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Kuvaresoluutio

- Kun kuvien käyttökohde on web-sivu tai multimediaesitys on 
helpointa unohtaa resoluutiot ja mieltää kuvat pikseli x pikseli
kokoisina

- Resoluutiolla on merkitystä kun kuva tulostetaan. Esimerkiksi 300 x 300 
pikseliä 300 dpi:n resoluutiolla oleva kuva on resoluution määritystä 
lukuunottamatta identtinen 300 x 300 pikseliä 72 dpi:n resoluutioisen kuvan 
kanssa, mutta tulostettaessa ensin mainittu tulostuu 2,54 x 2,54 senttisenä ja 
jälkimmäinen 10,58 x 10,58 senttisenä

- Monitorien kokoja ja niiden näyttöresoluutioita

1280 x 960
1600 x 1200

21

1024 x 768
1152 x 864
1280 x 960

19

1024 x 768
1152 x 864

17

800 x 600
1024 x 768

15

(suositeltava) näyttöresoluutiokoko (tuumina)
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Kuvaresoluutio

- Jos viivottimella aletaan mittaamaan monitorilta kuvan resoluutiota, 
vaihtelee se 72:n ja 101:n välillä monitorin koosta ja käytetystä 
näyttöresoluutiosta riippuen. Usein näytöllä käytettävän kuvan 
resoluutioksi annetaan 72 tai 96

- Painotuotteiden resoluutioita ja linjatiheyksiä

- Painettaessa kuva rasteroidaan ja ohjesääntönä on, että kuvan 
resoluutio on 1,6 – 2 kertaisesti painatuksessa käytettävää 
(rasteri)linjaa

Es

A

S

P

150 lpi300 dpiite

133 – 150 lpi250 – 300 dpiikakauslehti

75 – 100 lpi170 – 200 dpianomalehti

Painatuksen linjatiheysKuvan resoluutioainotuote
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Kalibrointi

- Olennainen osa kuvankäsittelyä on, että työvälineet (skanneri, 
monitori ja tulostin) ovat kalibroituja

- TFT-näyttö ei ole ideaalinen kuvankäsittelylle, koska näytön 
kirkkaus vaihtelee käyttäjän katselukulmasta riippuen

- Tarkoituksena oli ensimmäisenä harjoituksena tehdä silmämääräinen kalibrointi 
luokan monitoreille, mutta ei siitä olisi tullut mitään, eli se siitä…

- Mielenkiintoinen artikkeli gammasta ja monitorin kalibroinnista:
http://www.normankoren.com/makingfineprints1A.html#Monitorsetup
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Kuvien tallennusformaatteja

- Compuserve GIF
- 8-bittinen (256 väriä)
- Häviötön pakkaus
- Web-käyttöön mustavalkokuvien ja grafiikan esityksessä
- Mahdollistaa läpinäkyvyyden, animaation, lomitetun kuvan (kuva piirtyy näytölle 

terävöityen. vrt. lomittamaton piirtyy ylhäältä alas)
- JPG (Joint Photographic Experts Group)

- Hävittävä pakkaus, jonka pakkaussuhteen voi määritellä
- Web-käyttöön väri ja sävykuvien esityksessä

- PNG (Portable network graphics)
- Yhdistää GIF:n ja JPG:n hyvät puolet
- Suositellaan web-käyttöön, vaikka selaimilla on (yhä) vaikeuksia sen 

esittämisessä 
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Kuvankäsittelyohjelmat

-Vuonna 1994 ilmestyi Photoshop 3.0, 
jonka uutena ominaisuutena oli 
Layerit

- Mahdollisti kuvien koostamisen 
päällekkäisissä kerroksissa.

- Tätä ennen kuvien yhdistämisessä oli 
käytettävä vaikeakäyttöistä alpha-
kanavaa maskina

- Tämän jälkeen muutokset eivät ole 
olleet yhtä mullistavia

- Photoshop 4: käyttöliittymän viilausta
- Photoshop 5: history –paletin lisäys
- …

- Kuvankäsittelyohjelmien välillä ei ole 
suuria eroja

- Jako toolboxiin, workspaceen ja 
paletteihin, layerit

- Ikoneissa samaa symboliikkaa, 
työkalujen ja toimintojen nimet 
vähintään synonyymejä

- Vieressä ruutukaappaukset Gimp2:sta 
ja Photoshop 5:stä
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Adobe Photoshop 5: Toolbox
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Adobe Photoshop 5: Toolbox

Useimmin käytetyt työkalut:
- Marquee, Lasso ja/tai Magic wand

- Käytetään aktiivisen alueen valisemiseen
- Valittua aluetta pystyy laajentamaan painamalla shift alas kun käyttää em. työkaluja ja 

vastaavasti pienentämään painamalla alt-näppäintä.
- Select-valikossa on toimintoja aktiivisen alueen valitsemisen käsittelyyn

- Invert kääntää aktiivisen alueen valinnan toisinpäin
- Expand laajentaa aktiivista aluetta
- Feather pehmentää valitun alueen rajaa liulla

- Move
- Siirtää aktiivista layeriä tai jos aktiivinen alue on valittu, niin siirtää aktiivista aluetta 

aktiivisella layerillä
- Pikkutarkkaan siirtämiseen käy nuolinäppäimet

- Zoom
- Vastaavasti pienentäminen pitämällä alt-näppäintä alhaalla

- Crop
- Rajataan ja leikataan ylimääräinen kuvasta pois

HUOM! pitämällä hiiren vasenta painiketta alhaalla saa vaihtoehtoisia työkaluja 
(esittely edellisellä kalvolla oikealla puolella) näkyviin



13

Porin yksikkö / Advanced Multimedia Center Johdatus multimediaan 28.9.2004

Adobe Photoshop 5: Toolbox

Color picker – Photoshopissa on kaksi väriä käytössä: Foreground
color ja Background color. Piirtotyökalut käyttävät Foreground
coloria, mutta jotkut efektit käyttävät molempia (esim. difference
clouds). Molemmat väri määritellään color pickerillä
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Adobe Photoshop 5: Paletti 1

Navigator – Samat toiminnot pystyy tekemään myös zoom-työkalulla ja 
scrollaamalla workspacea. Ehkä tätä on mielekkäämpi käyttää, kun käsitellään 
isoa tiedostoa
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Adobe Photoshop 5: Paletti 1

Info – Antaa tietoa osoittimen alla olevasta pikselistä: Väri, läpinäkymättömyys ja 
kordinaatit sekä pituus ja leveys kuvioita piirrettäessä tai aktiivista aluetta 
valittaessa. Näytettävän mittayksikön saa vaihdettua klikkaamalla ikonia (pipetti 
tai plussa) 
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Adobe Photoshop 5: Paletti 1

Options – Optionsin valinnat vaihtelevan sen mukaan, mikä työkalu on käytössä. 
Uudemmissa Photoshopeissa työkalujen valinnat on siirretty työkaluriviin.
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Adobe Photoshop 5: Paletti 2

Color – Värit voi määrittää myös toolboxin värivalitsimesta. 
Mittayksikön vaihto oikealla ylhäällä play-nappulalta näyttävästä 
painikkeesta
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Adobe Photoshop 5: Paletti 2

Swatches – Valmiiksi määriteltyjä värejä



19

Porin yksikkö / Advanced Multimedia Center Johdatus multimediaan 28.9.2004

Adobe Photoshop 5: Paletti 2

Brushes – Piirtotyökalujen, leimasimen ja pyyhekumin kärjen valinta. 
”play-nappulasta” pääsee muokkaamaan valittua ja tekemään oman 
kärjen.
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Adobe Photoshop 5: Paletti 3

History – Sallimalla non lineaarisen toimenpiteiden rekisteröinnin 
(”play-nappula” ja history options) on mahdollista poistaa tehtyjä 
toimenpiteitä välistä
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Adobe Photoshop 5: Paletti 3

Actions – Jos monelle kuvalle tarvitsee tehdä useampi mutta samoilla 
arvoilla suoritettavia toimenpiteitä, kannattaa ne koota yhdeksi
actioniksi
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Adobe Photoshop 5: Paletti 4

Layers – Kuvan hajoittaminen mahdollisimman monelle layerille
helpottaa jälkikäteen tehtävää kuvan viilaamista
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Adobe Photoshop 5: Paletti 4

…
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Adobe Photoshop 5: Paletti 4

Channels – Kuvankäsittelyä voi suorittaa myös kanavakohtaisesti
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Adobe Photoshop 5: Paletti 4

Paths – Bezier-käyriä tekevän pen-työkalun tekemiä polkuja pystyy 
käsittelemään täällä. Esimerkiksi piirtää valittu polku halutulla 
työkalulla kuvaan
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Tehtävä 1

- Käynnistä Photoshop, jos se ei jo ole auki
- Valitse File->New

- aseta uuden kuvan leveydeksi 400 pikseliä ja korkeudeksi 100 pikseliä
- aseta moodiksi RGB color ja kuvan resoluutioksi 72 pixels/inch
- aseta taustaksi transparent
- paina ok

- Säädä foregroundcoloriksi punainen (255,0,0) ja 
backgroundcoloriksi musta (0,0,0)

- Valitse tekstityökalu ja kirjoita kuvaan vaikkapa oma nimesi
- Fontti sekä sen tyyli ja koko maun mukaan, mutta pyri täyttämään

mahdollisimman paljon kuvan pinta-alasta
- Move-työkalulla voit liikuttaa tekstiä

- Lisää uusi layer
- Layer-paletista new layer ja ok
- Vedä uusi layer tekstilayerin alapuolelle

- Valitse tekstilayer aktiiviseksi, jos se ei jo sitä ole
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Tehtävä 1

- Valitse Magic wand –työkalu ja klikkaa kuvassa tyhjään kohtaan
- Tolerance säädöllä ei nyt ole merkitystä, kun valitaan tyhjää, mutta sillä 

määritellään kuinka lähellä valittua väriä olevat värit tulevat valituksi
- Anti-aliased on syytä olla päällä, että valitun alueen reunoista tulee pehmeät

- Valitse Select->Similar
- Nyt kaikkien tyhjien alueiden pitäisi olla valittuna

- Valitse Select->Feather
- Pehmentää valitun alueen reunoja
- Anna arvoksi 2 pikseliä ja ok

- Valitse Select->Inverse
- Valitse aiemmin tekemäsi uusi layer aktiiviseksi
- Valitse Edit->Fill

- Valitse täytön väriksi backgrouncolor
- Valitse Select->Deselect

- Poistaa aktiivisen alueen
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Tehtävä 1

- Pidä ”uusi” layer edelleen aktiivisena ja valitse move-työkalu
- Liikuta layeriä nuolinäppäimillä kolmen pikselin verran alas ja kahden pikselin

verran oikealle
- Nyt kuvassa pitäisi olla punaisella kirjoittamasi teksti, joka on 

varjostettu
- Voit säätää varjostuksen tummuutta säätämällä varjolayerin opacityä

- Tallenna kuva varmuuden vuoksi kovalevylle (Johonkin d-asemalle)
- Valitse File->Save
- Tallennusformaattina Photoshop ja nimeksi vaikkapa kuva.psd

- Valitse Image->Duplicate
- Voit antaa kuvan kopiolle nimen, mutta se ei ole ainakaan tällä kertaa tarpeen

- Valitse Layer->Flatten Image
- Tämä yhdistää kuvan layerit yhdeksi layeriksi (background)

- Valitse zoom-työkalu ja suurenna kuva 400%:ksi
- Valitse crop-työkalu ja yritä rajata pois mahdollisimman paljon 

tyhjää valkoista taustaa
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Tehtävä 1

- Tallenna kuva
- File->Save
- Tallennusformaattina JPEG ja nimeksi kuva.jpg
- pakkaussuhteeksi vaikkapa 8

- Sulje äsken tallennettu kuva ja ota alkuperäisestä kuvasta uusi 
kopio

- Valitse Image->Duplicate
- Valitse Layer->Flatten Image
- Valitse Image->Mode->Indexed Color

- Valitse paletiksi adaptive, värien määräksi 128 ja ditherin arvoksi none
- Tallenna kuva

- File->Export->gif89 Export
- Valitse valkoinen väri transparentiksi
- Anna nimeksi kuva.gif

- Sulje äsken tallennettu kuva ja siirry muokkaamaan alkuperäistä 
kuvaa
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Tehtävä 1

- Valitse varjolayeri ja linkitä tekstilayeri siihen
- Linkitys tapahtuu klikkaamalla slimän oikealla puolella olevaa neliötä

- Yhdistä layerit yhdeksi layeriksi valitsemalla merge linked
- Tallenna kuva

- File->Save a Copy
- Valitse formaatiksi PNG ja nimeksi kuva.png

- Nyt sinulla pitäisi olla samassa (omavalintaisessa) kansiossa kolme kuvaa: 
kuva.jpg, kuva.gif ja kuva.png

- Avaa notepad (= muistio) ja kirjoita (tai copypasteta) alla oleva html-koodi ja 
tallenna se samaan kansioon tekemiesi kuvien kanssa nimellä testi.html

<html>
<head><title>testi</title></head>
<body bgcolor="green">

<img src="kuva.jpg"><p>
<img src="kuva.gif"><p>
<img src="kuva.png"><p>

</body>
</html>
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Tehtävä 1

- Avaa tekemäsi html-sivu web-selaimessa ja totea, että png-tiedosto
ei toistu niin kuin pitäisi.

- Drag’n’droppaa kuva.psd Gimpin (toinen kuvankäsittelyohjelma) 
ikonin päälle

- klikkaa oikealla hiirennäppäimellä kuvaa ja valitse File->Save a Copy
- Tallenna kuva edellisen päälle ja anna kuvan nimeksi kuva.png
- Ohjelma haluaa exportata kuvan ja se on oukkei (Gimp 2:ssa pitää valikosta 

poistaa ruksi kohdasta save background color)
- Avaa tekemäsi html-sivu web-selaimessa uudestaan

- IE ei toista vieläkään png-kuvan läpinäkyvyyttä oikein
- Avaa sama sivu Mozillalla

- Tee havaintoja eri talletusformaateista
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Tehtävä 2

- Tee ainakin yksi seuraavilta sivuilta löytyvistä tutorialeista:
- http://www.n-sane.net/tutorials.php
- http://www.stealthdesignz.com/index2.php?page=photoshop
- Nämä tutorialit on tehty Photoshop 7:lle, mutta suurimman osan niistä pystyy 

tekemään myös Photoshop 5:llä iman suurempaa viilaamista
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